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Introduction
This document provides step−by−step installations and integrations of CUCILync with Microsoft Lync 2010
and Cisco Unified Communication Manager.
Note: The document covers steps that are required to install AD, Exchange and Lync in the lab and does not
cover CUCM, Cisco Unity Connection.

Prerequisites
Requirements
For staged approach to the Standard Edition Lync deployment, this is the minimum configuration required to
run Lync. The initial Standard Edition topology deployment described in this document includes these
environment and components:
• A single forest, single domain Active Directory structure.

• A single domain controller with Domain Name System (DNS) and an Enterprise Root certification
authority (CA)
• Exchange

Components Used
The information in this document is based on these software and hardware versions:
• Active Directory Server
• Exchange Server
• Lync 2010 Server
• Cisco Unified Communication Manager (CUCM) 8.5
• PC Client Machine
Note: VMWare for AD, Exchange and Lync.
The information in this document was created from the devices in a specific lab environment. All of the
devices used in this document started with a cleared (default) configuration. If your network is live, make sure
that you understand the potential impact of any command.

Conventions
Refer to the Cisco Technical Tips Conventions for more information on document conventions.

Cisco UC Integration for Microsoft Lync
Microsoft Lync Server 2010 communications server offers instant messaging (IM), presence, conferencing,
and telephony solutions that can support enterprise−level collaboration requirements.
Cisco Unified Communication Integration (CUCI) for Microsoft Lync is a desktop integration that provides
access to Cisco Unified Communications for Microsoft Lync. The solution extends the presence and instant
messaging (IM) capabilities of Microsoft Lync by providing access to a broad set of Cisco Unified
Communications capabilities, which includes softphone standards−based video, unified messaging, audio,
video and web conferencing, desk−phone control, and phone presence.
Cisco UC Integration for Microsoft Lync is tightly integrated with Microsoft Lync to deliver a consistent and
compelling user experience while providing the benefits of increased employee productivity and
collaboration, reduced infrastructure complexity, and a lower total cost of ownership (TCO).

Configure
These are the pre−requisites for CUCILYNC integration.
1. After the installation of Pre−requisites install Active Directory (AD)
2. Create Users inside Active Directory
3. Activate DNS and add DNS entries for Servers and Clients
4. Activate Certificate Authority (CA) Services on the same server
5. After installing Pre−requisites install Exchange
6. Create Mailbox
7. Verify email exchange through Outlook
8. After the installation of Pre−requisites install Microsoft Lync 2010 server
9. Verify IM & Presence with native Lync 2010 client

10. Install Lync 2010 Clients on PC.
11. Install Outlook 2010 and configure user Mailbox

Network Diagram
This document uses this network setup:

Install Active Directory Server
Install Active Directory Domain Services (AD DS) on a member server that runs Windows Server 2008 R2
with the Active Directory Domain Services Installation Wizard (Dcpromo.exe).
The member server should be located in the forest root domain. After you install AD DS successfully, the
member server becomes a domain controller.
You can install AD DS with the Windows user interface (UI). The Windows UI provides two wizards that
guide you through the installation process for AD DS. One wizard is the Add Roles Wizard, which you can
access in Server Manager. The second wizard is the Active Directory Domain Services Installation Wizard
(Dcpromo.exe). Complete these steps for installation.
1. Disable IPv6 with these steps:

♦ Uncheck it on the network adapter in order to disable IPv6.

♦ In order to add the DWORD to the registry, choose Run and type Regedit. Then choose
HKEY_LOCAL_MACHINESYSTEM > CurrentControl > SetServices > Tcpip6 >
Parameters > DisabledComponents and set the value to 0xFFFFFFFF.

2. Start the Server Manager and start the installation of the AD DS role. For that from Server Manager,
Click Add Roles.

3. On the Add Roles wizard window, click Next.

4. Choose the Active Directory Domain Services Role.

5. You are prompted to install the .NET framework 3.5.1 features. Choose Add Required Features and
click Next.

6. An introduction to Active Directory Domain Services appears with some points to note that you have
to read. Then click Next.

7. Next is the confirmation and summary page of the role installation. Click Install.

8. When the installation role finishes. Click on Close.

Active Directory Domain Services Installation Wizard
Complete these steps in order to install Active Directory.
1. Choose Start > Run and type dcpromo.
2. On the window that appears, uncheck Use advanced mode installation and click Next.

3. Choose Create a new domain in a new forest.

4. Set the FQDN of the forest root domain as sjclab.com. You can give any name here based on your
domain name.

5. Set the Forest functional level to Windows Server 2008 and click Next.

6. Set the Domain functional level to Windows Server 2008 R2 and click Next.

7. Choose additional options for this domain controller. Ensure that the DNS server is checked and
clickNext.

8. The A delegation for this DNS server cannot be created... Do you want
to continue? message appears. Click Yes. This particular setup assumes a brand−new forest and
everything, so no action is required.

9. Default Database / Log files / SYSVOL folder locations as C:\Windows\NTDS should be fine,
when you create a smaller deployment with less loads. Otherwise you need to reconsider the
locations. Click Next after you choose those locations.

10. Enter a Directory Services Restore mode administrator password and click Next.

11. On the Summary Window, click Next.

12. The Installation continues to proceed. Click Finish when it is done.

13. Then the system restarts.

Create Users Inside Active Directory
Complete these steps in order to create a new user:
1. Choose Start > All Programs > Administrative Tools >| Active Directory Users and Computers.
2. Create a new user object in the current container

3. Enter the New User details and password. Click Next.

4. Click Finish and then the new user is created.

5. Now right click on the newly created user and choose Properties.
6. On the Window that appeared in the General tab, ensure that you add E164 Telephone number to AD
Users.

Create DNS Entries for Servers and Clients
Complete these steps in order to accomplish the task.
1. The first step is to configure the Reverse lookup zone. This has to be done before you add the DNS
entries for Servers and Clients.

2. Choose Start > Administrative Tools > DNS.
3. Launch DNS Manager and navigate to the root domain, right−click on Reverse Lookup Zone and
choose the option to create New Zone in order to launch the wizard.

4. When the New Zone Wizard appears, click Next.

5. On the Zone Type page, choose Primary Zone, and then click Next.

6. On the Active Directory Zone Replication Scope page, choose replication To all DNS servers
running on domain controllers in the forest, and then click Next.

7. On the Reverse Lookup Zone Name page, in the Network ID field, type the start of the subnet range
of your network, and then click Next.

8. On the Dynamic Update page, choose Allow only secure dynamic updates and click Next.

9. On the Reverse Lookup Zone Name page, choose IPv4 Reverse Lookup Zone, and then click Next.

10. On the Completing The New Zone Wizard page, click Finish.

11. Now add DNS entries for Exchange, Lync servers and Lync clients. (Forward and Reverse DNS)
12. Launch DNS Manager and navigate to root domain under forward lookup zones.
13. Right−click on domain and choose New Host (A orAAAA) in order to add the DNS entry.

14. On the New Host wizard page enter the Name, IP Address and Check Create associated pointer
(PTR) record for reverse lookup entries and click Add Host.

Note: The steps from 12 to 14 have to be done for Lync Servers and Lync Clients with their
respective name and IP Address.

Certificate Authority Install
Complete these steps in order to accomplish the task.
1. Log on to AD as a domain administrator.
2. Choose Start > Administrative Tools > Server Manager.

3. In the Roles Summary section, click Add Roles.
4. On the Select Server Roles page, choose the Active Directory Certificate Services check box. Then
click Next two times.

5. On the Select Role Services page, choose the Certification Authority check box, and then click
Next.

6. On the Specify Setup Type page, click Enterprise, and then click Next.

7. On the Specify CA Type page, click Root CA, and then click Next.

8. On the Set Up Private Key and Configure Cryptography for CA pages, you can configure optional
configuration settings, which includes cryptographic service providers. But, for basic testing
purposes, click Next twice in order to accept the default values.

9. In the Common name for this CA box, type the common name for this CA, as ActiveDirectory, and
then click Next.

10. On the Set the Certificate Validity Period page, accept the default validity duration for the root CA,
and then click Next.

11. On the Configure Certificate Database page, accept the default values or specify other storage
locations for the certificate database and the certificate database log, and then click Next.

12. After the verification of the information on the Confirm Installation Options page, click Install.

13. Review the information on the confirmation screen in order to verify that the installation was
successful.

Install Exchange 2010
The integration of Lync 2010 and Exchange provides users with features like instant messaging (IM),
enhanced presence, telephony, and conferencing capabilities of Lync within the Microsoft Outlook messaging
and collaboration client.
Complete these steps in order to install the pre−requisites for exchange 2010:
1. Add the exchange server to the domain and verify dns entry.

2. On servers that host the Hub Transport or Mailbox server role, install the Microsoft Filter Pack.

3. On the Start Menu, choose All Programs > Accessories > Windows PowerShell. Open an elevated
Windows PowerShell console, and run the Import−Module ServerManager command.
4. Use the Add−WindowsFeature cmdlet in order to install the necessary operating system
components: For a server that has the typical installation of Client Access, Hub Transport, and the
Mailbox role: Add−WindowsFeature
NET−Framework,RSAT−ADDS,Web−Server,Web−Basic−Auth,Web−Windows−Auth,Web−Met
−Restart

5. On servers that have the Client Access Server role installed, after the system has restarted, log on as
an administrator, open an elevated Windows PowerShell console, and issue the Set−Service
NetTcpPortSharing −StartupType Automatic command in order to configure the Net.Tcp Port
Sharing Service for Automatic startup.
6. Install Unified Communication Managed API 3.0.

7. Similarly Install Speech Runtime and Disable IPv6.

Install Exchange
Complete these steps in order to accomplish the task.
1. Install Exchange −run setup from the Exchange DVD.

2. Click I accept Licensing Agreement and click Next.
3. Click No for Error Reporting and click Next.
4. Choose Typical Exchange for Server Installation for this simple deployment, and verify the path
for the installation.

5. Provide the Exchange Organization name, such as Cisco Organization.

6. No legacy client support is needed in this case. Choose No and click Next.

7. Set the Client Access server external domain: asmail.sjclab.com

8. After the readiness checks, click Install.

9. Restart the server.
10. Launch the Exchange Management Console and complete the GUI prompts to install it.

Exchange Certificate Install
When the Exchange Server 2010 Client Access Server role is installed, a self−signed certificate is installed
automatically, primarily for testing purposes. But, as soon as the installation is finished, a real certificate
should be acquired and installed. Exchange Server 2010 uses a Unified Messaging certificate, which holds
besides its Subject Name other names as well, called the Subject Alternative Names (SAN).

Create Mailbox Users in Exchange
Choose Recipient Configuration > Mailbox and choose New Mailbox.

Query for Active directory users and Add users. Once you finish adding, the users added appear:

LYNC SERVER 2010 INSTALL
Microsoft Lync Server 2010 communications software and its client software, such as Microsoft Lync 2010,
enable users to connect in new ways and to stay connected, regardless of their physical location. Lync 2010
and Lync Server 2010 bring together the different ways that people communicate in a single client interface,
are deployed as a unified platform, and are administered through a single management infrastructure.
Deployment of Microsoft Lync Server 2010, Standard Edition requires the use of Topology Builder in order
to define your topology and the components you want to deploy, preparing your environment for deployment
of the Lync Server 2010 components, importing and publishing your topology design on the Standard Edition
server, and then installing and configuring Lync Server 2010 software for the components for your
deployment.
While the IM and presence features are automatically installed in every Lync Server deployment, you can
choose whether to deploy conferencing, Enterprise Voice, and remote user access. In this example, other
features are not enabled since Enterprise Voice using Cisco Unified Communications is enabled.

Install Lync Pre−Requisites
Complete these steps in order to accomplish the task.

1. Add lync server to the domain and verify dns entry.
2. Disable IPv6.
3. On the Start Menu, choose All Programs−> Accessories> Windows PowerShell. Open an elevated
Windows PowerShell console, and run the Import−Module ServerManager command.
4. Use the Add−WindowsFeature cmdlet in order to install the necessary operating system components:
Add−WindowsFeature
NET−Framework,RSAT−ADDS,Web−Server,Web−Static−Content,Web−Default−Doc,Web−
−Restart
5. Install Microsoft Silverlight, which s needed to run the Lync Server 2010 installation GUI. Refer to
Microsoft Silverlight for more information.

6. Create a shared file with name LyncShare with appropriate rights such that everyone has Full Control
on the Lync server 2010. You can create the share in any location with any name.
7. Create these DNS entries
♦ dialin.sjclab.com
♦ meet.sjclab.com
♦ admin.sjclab.com

8. Install Windows Media Format (WMF) runtime before you run the Lync Server 2010 setup and then
restart the server. If you issue this command, this requires permissions equivalent to the Windows
server−based computers Local Administrator account.

Here's the cmdline to install on Windows Server 2008 R2 SP1:
%systemroot%system32dism.exe /online /add−package
/packagepath:%windir
%servicingPackagesMicrosoft−Windows−Media−Format−Package~31bf3856ad364e35~amd64~~6.1
/ignorecheck

After Windows Media Format Runtime is installed and the system is rebooted, proceed with the
typical Lync Server 2010 setup in order to complete the installation.
Install Lync 2010 Server
Complete these steps in order to accomplish the task.
1. Insert your Lync Server 2010, DVD.If AutoPlay does not start, navigate to your drive Setupamd64
and execute setup.exe. The first thing you need to do is to install Microsoft Visual C++ 2008
Redistributable Package, and then click Yes in order to proceed.

2. When Microsoft Visual C++ 2008 Redistributable Package is installed you need to choose the
installation directory. The default location is fine, or you can change the location to match your
preferences and then click Install.

3. Next you need to accept the license agreement. Check I accept the terms in the license agreement
and then click OK.

4. Now the Deployment Wizard launches and you have these choices.
Complete these steps in this order:
a. Prepare Active Directory
b. Prepare First Standard Edition Server.
c. Install Topology Builde
d. Launch Topology Builder & Publish Topology
e. Install or Update Lync Server System

Prepare Active Directory
Complete these steps:
1. First step is Prepare Schema wizard. Click Run in order to start the wizard.

2. The next step is to Prepare Current Forest. Click Run to start the wizard.
3. The last preparation wizard you need to run is Prepare Current Domain and then click Run to start
the wizard.
4. Now grant access to the Microsoft Lync Server 2010 Control Panel. Complete these steps in order to
accomplish the task.
♦ Log on as a member of the Domain Admins group into Active Directory Server.
♦ Open Active Directory Users and Computers, expand your domain, right−click the Users
container, and then click Properties.
♦ In Domain Admin Properties, click theMember Of Tab.
♦ On the Members tab, click Add. In Select Users, Contacts, Computers, Service Accounts, or
Groups dialog, locate the Enter the object names to select. Type the user name(s) or group
name(s) to add to the group CSAdministrators. Click OK.
♦ On the Members tab, confirm that the users or groups that you selected are present. Click
OK.
After the completion of these steps, click on Back in order to return to the Deployment Wizard.
Prepare the First Standard Edition Server
Choose the option to Prepare first Standard Edition Server (top right hand option). This installs a copy of SQL
2008 Express, Lync Server core installation files and creates an RTC database.

Install Topology Builder
Install the Topology Builder via the main deployment screen. When this completes, you gain a green tick in
order to signify a successful install.

Launch the Topology Builder and Publish Topology
Complete these steps in order to accomplish the task.
1. Launch the topology builder through the start menu.
2. Choose New Topology and click OK.

3. Choose where to save your topology files. For example, C:\Lync Server 2010 Topology Builder and
call it MyTopology.tbxml. When you are finished choosing name ad location click Save.
4. Then enter a SIP domain that matches company preferences, sjclab.com. This is the internal domain
name in AD family domain and works well for the purpose of this installation, click Next to continue.
5. Enter a name of the default site, then click Next to continue.
6. Here you need not add any additional SIP domains at this point, click Next to continue.
7. Enter your City, State and Country and click Next to continue.
8. Continue to configure a front end pool so click Finish. When the New Front End Pool wizard starts
click Next to continue.

9. Now define a FQDN for our Front End Pool. Since this is a simple single server installation use the
servers FQDN sjclab.com and choose Standard Edition Server and click Next to continue.
10. Lync Server Installation enables Presence and IM by default.
11. In order to collocate the mediation server, check Collocate Mediation Server role and then click
Next.
12. Choose any other roles to enable more components; if not click Next to continue.
13. SQL server has already been installed on the Lync Server 2010 server and the wizard finds it
automatically. Click on Next to continue.
14. Now enter the share folder name, which was created in the Pre−Requisites section. Enter public File
Server FQDN: lync.sjclab.com and share folder name LyncShareand click Next to continue.

15. Skip adding a gateway at this moment and specify the External Base URL: lync.sjclab.com, which
can be same as your internal or can be different. Click Finish to complete defining Front End Pool
wizard.
16. When the wizard closes you arepresented with the Topology builder. Take a moment to go through
the configuration, then go back to the original screen and click on Edit Topology.
17. In the left pane, choose Simple URLs, in the main pane, enter a URL in the field Administrative
access URL. Here this is https://admin.sjclab.com, then choose the Front end server to install
Central Management Server on. If all is well you should only have one choice here, click Ok when
done.

18. Now it is time to publish the topology that was built to the management server. Back in the topology
builder, click on Publish Topology in the Actions Pane.

19. When the wizard has loaded, click on Next to start the publishing.
20. You should only have one Central Management Server, make sure it is selected in the drop−down list
and then click Next.
21. When the wizard completes, make sure that all steps are successful and then click. Finish.

Install/Update Lync Server System
In order to finish Lync server installation, go to initial Lync Server Deployment Wizard, which is accessible
now through the start menu. Choose Install or Update Lync Server System to continue.

Here you need to click Run Button corresponding to each steps.
After you complete the Start Services task, if Lync Deployment Wizard does not show the task as completed,
then go to msservices.exe to make sure that all the Lync services are started.
Finally you need to create a SRV DNS record for your new Lync Server. Without this record, your Lync
client is unable to locate the server location. In order to create one, access your DNS manager and right−click
the Forward Lookup Zone for your SIP FQDN. Then click Other New Records and Service Location
(SRV). Complete with the server settings as in this example:

Add Users in Lync
Complete these steps in order to add users in Lync.
1. Choose Start > All Programs > Microsoft Lync Server 2010 > Lync Server Control Panel.

2. Once you login with your Lync credentials into the Lync Server Control Panel, it opens the Control
Panel window.

3. You can add users. Choose LDAP search, and click Find. Here in this example the query does not
list any users even though LDAP users are present so you can see none of those users are enabled.

4. Enable LDAP users using Enables users. Once you click on Enable users, it brings up New Lync
Server Users window where you can Add LDAP users.

5. Do an LDAP search, which returns all the users in LDAP. Select all the users you want to add and
click Ok.

6. Edit all the users to change Telephony settings to Audio/Video disabled (Recommended) and
Commit the changes.

7. Try to log into Client Lync with one of the above user credentials to make sure that login works fine.
Note: It is recommended not to select the following telephony options for users:
♦ Enable Remote call control
♦ Enable Enterprise Voice

Install Lync on Client PC
Lync 2010 delivers easy and engaging access to multiple communication modes through a single, simplified
interface. Users can connect and collaborate from any location that has Internet connectivity. Before proceed
to install ensure the following:
1. Client PC needs an entry in DNS and also needs to be part of the Domain
2. Ensure that root certificate on client is installed so that client trusts certificate from Lync.
Complete these steps in order to install the Root Certificate on to the client machine.
a. Login into CA Server from https://<CA Server>/certSrv and download the CA Certificate,
with the name certnew.cer.

b. View and install the CA Root Certificate on to the client machines.

c. Certificate Import Wizard is launched.

d. Browse the certificate store where you want to place the certificates.

e. Click on Finish to complete the Certificate Import.

f. Click Yes on the security warning.

g. Successfully imported the CA root certificate.

h. In order to verify if the certificate is loaded to the Trusted Root Certificates, choose Start >
Run > mmc (Microsoft Management Console).

i. Choose File > Add/Remove Snap−in, and add Certificates Snap−in under Selected
snap−ins. Click Ok

j. Add My User Account Certificate snap−in: and click Finish

k. Similarly repeat step i and Add Computer account for certificates snap−in.

l. Now the Add/Remove Snap−in page looks like this.

m. On the mmc page, choose Certificates − Current User > Trusted Root Certificates >
Certificates, and verify if you noticed the certificate that you installed earlier exists or not.

n. Now copy this certificate and save it in Certificates (Local Computer) −> Trusted Root
Certificates −> Certificates.

o. Save the console changes if needed and Close MMC.

Install Lync 2010 Client
Complete the steps in order to install Lync 2010 client.
1. Run the LyncSetup.exe file to install Lync 2010 client on user PC.

2. The Install succeeded message appears:

3. First time login or changing the Sign−in Address prompts for the username and password.

CUCI−LYNC configuration
The Cisco UC Integration for Microsoft Lync works with these applications:
• Microsoft Lync
• Microsoft Office Communicator
Cisco UC Integration for Microsoft Lync uses Cisco Unified Client Services Framework. Cisco Unified Client
Services Framework provides Cisco telephony services and next−generation media services for Cisco UC
Integration for Microsoft Lync. The integration works in the same way with each of these applications. The
Cisco UC Integration for Microsoft Lync adds a Cisco UC pane at the bottom of the Microsoft Lync or
Microsoft Office Communicator window. The picture shows the topology for Cisco UC Integration for
Microsoft Lync Interactions with Network Servers.

Integration Notes
1. Active Directory provides Phone Numbers for CUCILYNC.
2. Lync server expects the phone numbers to be in E.164 format, and rejects any numbers that are not in
this format.
3. If the numbers in Active Directory are not in +E.164 format, then configure normalization rules to
ensure that Lync client downloads +E.164−formatted numbers from the Lync server.
4. Lync server creates an address book, which is downloaded by Lync Client
5. Ensure that the user IDs, devices, and directory numbers match in AD, Lync and CUCM.
6. Configure users so that each user has a phone number that can be correctly dialed within the context
of your CUCM configuration.
7. When you place a call to a contact in Lync, the phone number is passed to CUCILYNC; CUCILYNC
uses the number to call the contact through CUCM.

8. CUCILYNC also uses LDAP directly to search for contact information.
9. When you display a CUCILYNC contact card, the full name and organization information comes
from an LDAP search of Active Directory.
10. When you receive a call, the LDAP connection to Active Directory is used to search for caller
information to match the incoming number.
11. CSF client can use either Enhanced Directory Integration (EDI) or Basic Directory Integration (BDI)
mechanisms to retrieve contact information from Active Directory.
12. EDI is recommended since it uses native Windows APIs and you might not need to do any further
configuration and also provides significant advantages over BDI.

CUCM Configuration
In order to accomplish this task you need to create Client Service Framework (CSF) Device in CUCM,
which gets registered when the Call Control is connected to Lync 2010 and operates in Softphone mode. The
Directory Number DN of this CSF device needs to be shared with the Actual Device of the user.
1. Configure CSF Device with the same Directory Number (DN) as Physical SEP Device.

2. Associate End user to the Shared Line DN from the CSF and SEP Device DN Configuration page.

3. Associate CSF Device and SEP Device to the end user Controlled Device list.

4. Configure Primary Extension on the End User page.

5. Assign End Users to User Groups.

6. When CUCILYNC is in SoftPhone Mode, you notice that the CSF Device is registered.

7. When CUCILYNC is in Deskphone Mode, CSF device is unregistered.

UC Integration for Microsoft Lync Installation
Configure Registry Keys for CSF Client IntegrationUse the Registry file in CUCI−Lync−Admin zip
folder that you download from CCO for the configuration of the Registry Settings for the CSF Client
Integration.

The explanation for each field is given here:
• TFTPServer AddressEnter the IP address or fully qualified domain name of the primary TFTP
server in your Cisco Unified Communications system, and any other TFTP servers. If you are using
certificates, the certificate common name must match the network identifier used to access to host,
that is, the IP address or the hostname.
Note: This is where CSF Device downloads its configuration file.
• CTI Server Enter the IP address or fully−qualified domain name of the primary CTIManager server
in your Cisco Unified Communications system, and the secondary CTIManager server, if present. If
you are using certificates, the certificate common name must match the network identifier used to
access to host, that is, the IP address or the hostname.

Note: Leave it blank, cause you want CUCM to determince the CTI server group.
• UseCUCMGroupForCtiSet this value to True if you want to use the relevant Cisco Unified
Communications Manager group information on the Cisco Unified Communications Manager server
to determine which CTI Servers to use instead of the CtiServer1 and CtiServer2 registry subkey
names.
Note: True: You want CUCM Group to determine the CTI Server Group.
• CcmcipServerEnter the IP address or fully−qualified domain name of the primary CCMCIP server
in your Cisco Unified Communications system, and the secondary CCMCIP server, if present. If you
are using certificates, the certificate common name must match the network identifier used to access
to host, that is, the IP address or the hostname.
• CcmcipServerValidationEnter the type of security certificate validation for Client Services
Framework to use with HTTPS to sign in to Cisco Unified Communications Manager to retrieve the
device list. Enter one of the following values:
♦ Client Services Framework accepts all certificates.
♦ Client Services Framework accepts certificates that are defined in the keystore and
self−signed certificates.
♦ Client Services Framework only accepts certificates that are defined in the keystore.
Note: Client Services Framework uses this certificate to verify the Cisco Unified Communications
Manager server. When the certificate is accepted, Client Services Framework must use the credentials
of the user to sign in to Cisco Unified Communications Manager.
• EnableNativeDirectoryProviderSpecify whether to use Enhanced or Basic Directory Integration to
get contact information from Active Directory. Enter one of the following values:
♦ Use Basic Directory Integration. This is the default value.
♦ Use Enhanced Directory Integration. Data type: REG_SZ
• VoicemailPilotNumber Enter the number of the voice message service in your Cisco Unified
Communications system. This value only relates to when users use the desk phone to access their
voice messages. If users are using the phone on their computer to access voicemail, the pilot number
comes from the voicemail pilot number associated with the voicemail profile configured on the Client
Services Framework device.
• VVM_SystemServer_XEnter the IP address or fully−qualified hostname of the Cisco Unity or
Cisco Unity Connection voicemail server.
Note: X : 0 for Primary Unity or Unity Connection Server and X : 1 for Secondary Unity or Unity
Connection Server

Install Cisco UC Integration TM for Microsoft Lync
Complete these steps to install CUCILYNC. Click Next on the wizard as shown in the screen shot.

Now you can login into CUCILYNC as shown in this screen shot and get the call control.

Related Information
• Release Notes for Cisco UC Integration for Microsoft Lync Release 8.5
• Installation Guide for Cisco UC Integration for Microsoft Lync Release 8.5
• Technical Support & Documentation − Cisco Systems
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